MacOS Mojave + Python 3.5.2 + pip3 = ошибка

PIP3 install для Python 3.5.2 не работает в MacOS X Mojave

При попытке вызвать pip3 install pika вылезает ошибка:

Could not fetch URL https://pypi.python.org/simple/pika/: There was a problem confirming the ssl certificate: [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:645) — skipping

Проблема в том, что наш дистрибутив Python 3.5.2 устарел, нужен новый, кленовый, решетчатый…

1. Ставим самый последний-распоследний питон с Python.org ( но без фанатизма). Я поставил релиз 3.7.0. Горячие финские парни могут поставить бета-версию и релиз-кандидат. Может и заработает.

2. Настраиваем в Pycharm интерпретатор. МасOS X python ставится в каталог /Library/Frameworks/Python.framework/Versions/3.7/bin, так что ищем его там…

3. Заходим в каталог /Library/Frameworks/Python.framework/Versions/3.7/bin и говорим

pip3 install <ваш пакет>

4. Удивительно, но все работает…